思いつくままを綴る雑記帳

暫く放置していたものが・・・

そうなんです・・・暫く放置していたんですが・・・
解決しました。

何かというと・・・Oblivionのダンジョン系のMODなんですが・・
猫さんがOblivionを始めた頃にあーでもない、こーでもないと
していた頃に導入したMODなんですが・・・
猫さんの初代の日本語環境では動いているんですが・・・
2代目のスリム化した日本語環境と英語環境では
変な現象が起こるので、ずっと導入しないでおいたんです。

どんな現象かというと・・・ゲームをロードするとポン!!
Cellを移動するとポン!!と・・・windowsの警告音が鳴るんです・・・
気にしないで続けていると・・・・・CTD!!!と・・・・

というわけで・・・それを遊びたければ初代環境を起動するしか
なかったのですが・・・・久しぶりにこの問題を調べてみようと
重い腰を上げたのですが・・・・

暫くスクリプトを眺めたり、デバッグコードを追加したりしていると
原因が判明・・・・そして解決策も分かりました。

複数のMODで構成されているんですが、そのうちの1つを少し
改造・・・・スクリプトを少し追加・・・・
これで、6時間くらいプレーしましたが・・・・
問題らしい問題はありませんでした。
それまでは2時間くらい動作すれば上出来だったのですが・・・
途中、猫さんが変なことをしたので一度だけCTDが発生しましたが
その後は快適に遊べました。
これで、全ての環境でポンポン鳴らずに遊べるようになりました。

作者様には、このような現象が発生していたので、こういうふうに変更したら
改善しましたと御報告だけはさせて頂きました。

( ̄-  ̄ ) ンー でも、1年以上そこにはアクセスされていない様子なので
連絡が着いたのかどうかは・・・・わかりませんが・・・
猫さんとしては・・・やるべきことはやりましたと・・・・

なんのMODかは書きません。
猫さんのところの環境だけの問題かもしれませんので・・・
そんなダンジョン帰りに自作のプライベート空間に寄り道・・・
ある家に入ると・・・・ポン!!・・・
Σ('◇'*)エェッ!? もう直ったはず・・・・・

確かに別の原因のポン!!でした・・・
猫さんのクローンNPCの首が・・・・見えません・・・・

( ´△`)アァ- そう言えば、ダンジョン系MOD入れた時にロードオーダーが
変わっちゃったのね・・・・( ´_ゝ`)ハイハイ・・・・

ちょっと待ってね・・・・猫さん自作のPEM_RepairModsIndex動かすから・・・
PEM_RepairModsIndexをアクティブにして・・・Oblivion再起動・・・

魔法を・・・・( ーノー)o/"Ω ポクポクポク…
どれがおかしいのかな・・・とリストを見ると・・・
ヾ(´▽`*)ゝあーい♪ 発見・・・じゃ、修復を選択して・・
再度ロードして、確認して・・・ちゃんと書き換わってたので・・・
保存して・・・・じゃ、もう一度ロードと・・・・

"\( ̄^ ̄)゛ハイ!! 首が戻りました・・・
こんな時だよね・・・作っておいてよかったと思うのは・・・
今までなら、( ´△`)アァ- ごめんねー・・・首取れちゃったね・・・
DeleteFullactorcopy・・・・・プチ(。・・)σ【ON】

だったんだけど・・・無事復活するんだから・・・
でも、ダンジョンでやったことは水の泡になりましたが・・・

まぁ、また今度潜りますから・・・・
スポンサーサイト

コメント

コメントの投稿

URL
コメント

パスワード
秘密
管理者にだけ表示を許可する

トラックバック

トラックバックURL : http://perfectcat.blog101.fc2.com/tb.php/209-552b3ae5
<< Weight PaintのTips | TOP | 気紛れに・・・ >>