思いつくままを綴る雑記帳

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Oblivionのシステムエラー音♪

タイトルだと何のことだか、よくわからないと思いますが・・・
OBSEのPluginのWeOcpsってやつなんだけど・・・
使っている人も多いよね・・判明しているCTDを引き起こす箇所に
パッチを当ててCTDを回避してくれるやつだよね

猫さんが普段メインで使っているOblivionの環境にも入れて
いるんだけど、動いてる?ってぐらいWeOcpsが動いたときに
聞こえるWindowsのシステムエラー音が鳴りません。
要するにWeOcpsが検知するような現象が起きてないんだと思うんだけど

昔はセル移動する度にポンポン鳴ってたんですよ・・・
ところが、何かをした拍子に途端に鳴らなくなったのを記憶しています。
で、あの時何をしたんだろうと思い出そうとしてたんだけど
( ̄-  ̄ ) ンー わからん・・・
結構前に鳴らなくなったのは覚えてるんだけど・・・
何をしたのかまでは思い出せません。

というのも、メイン使いの環境がそろそろMODの限界が近づいてきたので
軽い環境を別途作って普段はそちらで過ごそうかと思って新規環境を
構築したんです。
まぁ、基本はメイン使いの環境で使ってるMODを持ってくるから
問題はないだろうと高をくくっていたら・・・
例のポンポン音が鳴るわ鳴るわ・・・
ロードするとポン♪ちょっと移動するとポン♪
さすがに普段聞かなくなっていた音が鳴り出すと、気になる!
このポン♪が度重なると、途端に怪しい現象が発生するので・・

仕方なく、一旦全てのMODを切り離して一個ずつ検証していったん
だけど・・特定のMODを入れるとロードの時にポン♪~
( ゚_¨゚)´_¨`)ふむふむ あなたですか・・・
でも、そのMODは普段使いの環境で何の問題もなく動いている・・

MOD単体の問題ではなく、その環境で発生しているのかね~
で、そのMODを調べると起動時にスクリプトが走っているので
それを止める様に変更すると・・・ロードしても音が出ない。
( ̄-  ̄ ) ンー このスクリプトが原因?
でも、どう見ても問題があるようには見えないんですけど・・

その前にWeOCPSのログがない・・・音が鳴ったらログに出力
されるはずでは・・・これじゃ音が鳴った直接の原因が
わからんじゃん・・・困ったねぇ・・
幸いにもこのスクリプトはストップしても、後で動かせば
スクリプト自体は問題ないようで・・・でも、スクリプトが
動くと・・・途端にポン♪・・・・( ̄-  ̄ ) ンー
普段はスクリプトを止めておいて、必要なときだけスクリプトを
起動するしかないのかなぁ・・・

というか・・・このMODいるの? ( ̄-  ̄ ) ンー 似たようなの
自前で作っちゃう? などと・・・自問自答・・・
結論・・・別のMODに入れ替えることに・・・というか・・
新たに入れたMODって用途が違いますが・・・
まぁ、機能は違っても最終的な結果が似たものなら良しと・・
さすが・・・猫さん流・・・

今はいくら移動しても、ロードを繰り返しても一切WeOcpsの
発するWindowsのエラー音は鳴りません!

いろいろMOD入れてると、そこにこのファイルがあるはず!
と、思ってるところにそのファイルがなくなっていたりとか
WryeBashのパッチの作り方が悪くて参照が変になってるとか
思いもよらないことが原因になってCTDが発生することも
あるんでしょうね・・・

ロードやセル移動でポンポン音を鳴らしているあなた!
環境を見直したら、その音から開放されるかも知れませんよ

猫さんが環境を見直すのにTes4EditやCSを多用したのは
言うまでもありません・・・
おかげで導入していたMODから不要なデータや不正な参照が
書き換えられたMODも多数ございました・・・

スポンサーサイト

コメント

コメントの投稿

URL
コメント

パスワード
秘密
管理者にだけ表示を許可する

トラックバック

トラックバックURL : http://perfectcat.blog101.fc2.com/tb.php/173-c661d0b8
<< ゛(ノ・o・)ノジャーンプッ! 改造 | TOP | なんとなく・・・調べてみた >>
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。